Как посчитать количество ячеек в Excel

Как поставить пароль на папку либо файл
Дата: 2010-04-27
Автор: Каминский Олег

Как узнать какая видеокарта стоит на компьютере?
Дата: 2010-09-02
Автор: Каминский Олег

Как установить Windows XP с флешки
Дата: 2012-05-22
Автор: Олег Каминский

Автозагрузка программ в Windows 7
Дата: 2011-06-19
Автор: Олег Каминский

Как изменить разрешение экрана монитора
Дата: 2010-05-08
Автор: Каминский Олег

Как посчитать количество ячеек в Excel



Посчитать количество ячеек в Эксель может потребоваться в различных случаях. В данной статье, мы и рассмотрим, как посчитать ячейки с определенными значениями, пустые ячейки, и если они попадают под заданные условия. Использовать для этого будем следующие функции: СЧЁТ, СЧЁТЕСЛИ, СЧЁТЕСЛИМН, СЧИТАТЬПУСТОТЫ.

Для начала, рассмотрим самый простой способ. Если Вам нужно посчитать количество заполненных ячеек в Excel, выделите диапазон ячеек в документе – существуют различные способы, прочтите про них, перейдя по ссылке – и в «Строке состояния» обратите внимание на пункт «Количество». Там будет написано количество заполненных ячеек: учитываются ячейки с текстом, а пустые – нет.

Как посчитать количество ячеек в Excel

Если Вам нужно посчитать количество ячеек в таблице с определенными значениями и использовать это число в формулах для расчетов, то данный способ не подойдет, так как, данные в таблице могут периодически меняться. Поэтому перейдем к рассмотрению функций.

Функция СЧЁТ – подсчитывает ячейки, заполненные только числовыми значениями. Выделяем ячейку Н1, ставим «=», пишем функцию «СЧЁТ». В качестве аргумента функции укажите нужный диапазон ячеек (F1:G10). Если диапазонов несколько, разделите их «;»(F1:G10;B3:C8).

Всего заполнено 20 ячеек. Ячейка с текстом не была учтена, но посчитаны те, которые заполнены датой и временем.

Функция СЧЁТЕСЛИ – позволяет рассчитать количество нужных ячеек, которые соответствуют заданному критерию. В качестве аргумента прописывается диапазон ячеек – В2:В13, и через «;» указывается критерий – ">5".

Например, есть таблица, в которой указано, сколько килограмм определенного товара было продано за день. Посчитаем, сколько товаров было продано весом больше 5 килограмм. Для этого нужно посчитать количество ячеек в столбце Вес, где значение больше пяти. Функция будет выглядеть следующим образом: =СЧЁТЕСЛИ(В2:В13;">5"). Она рассчитает количество ячеек, содержимое в которых больше пяти.

Для того чтобы растянуть функцию на другие ячейки, и скажем поменять условия, необходимо закрепить выбранный диапазон ячеек. Сделать Вы это сможете, используя абсолютные ссылки в Excel.

Функция также может рассчитать:

– количество ячеек с отрицательными значениями: =СЧЁТЕСЛИ(В2:В13;"<0");
– количество ячеек, содержимое в которых больше (меньше) чем в ячейке А10 (для примера): =СЧЁТЕСЛИ(В2:В13;">"&A10);
– ячейки, значение в которых больше 0: =СЧЁТЕСЛИ(В2:В13;">0");
– непустые ячейки из выделенного диапазона: =СЧЁТЕСЛИ(В2:В13;"<>").

Применять функцию СЧЁТЕСЛИ можно и для расчета ячеек в Excel, содержащих текст. Например, рассчитаем, сколько в таблице фруктов. Выделим диапазон и в качестве критерия укажем "фрукт". Будут посчитаны все ячейки, с данным словом. Можно не писать текст, а просто выделить ячейку, которая его содержит, например С2.

Для формулы СЧЁТЕСЛИ регистр не имеет значения, будут подсчитаны ячейки содержащие текст «Фрукт» и «фрукт».

В качестве критерия также можно   использовать специальные символы: «*» и «?». Они применяются только к тексту.

Посчитаем количество товаров, которые начинаются на букву А: "А*". Если указать "абрикос*", то учтутся все товары, которые начинаются с «абрикос»: абрикосовый сок, абрикосовое варенье, абрикосовый пирог.

Символом «?» можно заменить любую букву в слове. Написав в критерии "ф?укт" – учтутся слова фрукт, фуукт, фыукт.

Чтобы посчитать слова в ячейках, которые состоят из определенного количества букв, поставьте знаки вопросов подряд. Для подсчета товаров, в названии которых 5 букв, поставим в качестве критерия "?????".

Если в качестве критерия поставить звездочку, из выбранного диапазона будут посчитаны все ячейки, содержащие текст.

Функция СЧЁТЕСЛИМН используется в том случае, когда требуется указать несколько условий, максимальное их количество в Excel – 126. В качестве аргумента: задаем первый диапазон значений, и указываем условие, через «;» задаем второй диапазон, и пишем условие для него – =СЧЁТЕСЛИМН(B2:B13;">5";C2:C13;"фрукт").

В первом диапазоне мы указали, чтобы вес был больше пяти килограмм, во втором выбрали, чтоб это были фрукты.

Функция СЧИТАТЬПУСТОТЫ рассчитает количество пустых ячеек в заданном диапазоне.

Посчитать в Экселе количество ячеек, которые содержат текст или числовые значения не так уж и сложно. Используйте для этого специальные функции, и задавайте условия. С их помощью можно посчитать как пустые ячейки, так и ячейки, с определенными словами или буквами.



Поделитесь статьёй с друзьями:

Автор: Аня Каминская| Дата: 2016-04-23| Просмотров:(28422)| Комментов:(3)


Похожие записи на сайте






Комментарии:

Автор: ОЛЬГА
Дата: (2017-02-23)

Подскажите, как подсчитать количество НЕпустых ячеек с применением фуекции ПРОМКЕЖУТОЧНЫЕ ИТОГи. Спасибо.

Автор: Вариант
Дата: (2017-01-25)

Посчитать количество равных букве Я и вычесть из общего количества ячеек :)

Автор: Олеся
Дата: (2017-01-17)

Подскажите, как посчитать количество ячеек, не равных букве - Я (если в строке много других букв)?

Добавить Ваш комментарий:

Введите сумму чисел с картинки: