Примеры функции СУММЕСЛИ и СУММЕСЛИМН в Excel

Установка Windows XP (4)

Настройка Windows XP (30)

Полезно знать (106)

Работа с программами (19)

Операции с винчестером (9)

Интернет (89)

Безопасность (25)

Реестр Windows (9)

Windows 7 (68)

BIOS (7)

Оборудование (30)

Горячие клавиши (5)

Выбор оборудования (9)

Установка Windows 7 (3)

Новости сайта (3)

Windows 10 (28)

Windows 8 (27)

Word (83)

Excel (27)

Photoshop (22)

Ошибки (11)

Программы (83)

Темы для Windows (5)

Видеоуроки (2)

Шрифты (2)

Как поставить пароль на папку либо файл
Дата: 2010-04-27
Автор: Каминский Олег

Как узнать какая видеокарта стоит на компьютере?
Дата: 2010-09-02
Автор: Каминский Олег

Как установить Windows XP с флешки
Дата: 2012-05-22
Автор: Олег Каминский

Автозагрузка программ в Windows 7
Дата: 2011-06-19
Автор: Олег Каминский

Как изменить разрешение экрана монитора.
Дата: 2010-05-08
Автор: Каминский Олег

Примеры функции СУММЕСЛИ и СУММЕСЛИМН в Excel



Функции СУММЕСЛИ и СУММЕСЛИМН помогут посчитать сумму для тех значений столбца, которые соответствуют указанному критерию.

Для примера рассмотрим следующую таблицу. В ней указано имя и пол ученика, в каком классе учится и средний бал. Используя функцию СУММЕСЛИ, решим такую задачу: посчитаем сумму значений из столбца «Средний бал» для всех мальчиков и для всех девочек. Задача для функции СУММЕСЛИМН такая: посчитать сумму среднего бала для мальчиков и девочек, которые учатся в 8 и 9 классе отдельно.

Примеры функции СУММЕСЛИ и СУММЕСЛИМН в Excel

Рассмотрим аргументы для СУММЕСЛИ.

=СУММЕСЛИ(диапазон; критерий; [диапазон суммирования])

Диапазон – здесь необходимо указать, тот столбец, данные в котором будут сравниваться с заданным Критерием. В примере, это Диапазон D2:D26.

Критерий – здесь нужно выбрать одно значение из ранее указанного Диапазона. Сначала будем указывать мальчиков, затем девочек.

Диапазон суммирования – это столбец, значения в котором нужно просуммировать, если они относятся к выбранному Критерию. Например, если для выбранного Диапазона D2:D26 указан Критерий «мальчик», значит в столбце «Средний бал»: С2:С26, будут суммироваться все значения, которые относятся к мальчикам.

Пример функции СУММЕСЛИ.

Выделяем ячейку G4 и ставим «=». Пишем в ней СУММЕСЛИ и открываем скобку «(». В качестве Диапазона, из которого будут выбираться значения, выделяем D2:D26. В качестве Критерия, нужно выбрать одно из значений в ранее указанном Диапазоне. У нас это «мальчик», поэтому выделяем ячейку D3. Диапазон суммирования – это столбец, в котором указан «Средний бал». Выделяем ячейки С2:С26. Между аргументами ставьте «;», в конце, закройте скобку «)». Нажмите «Enter».

Из исходной таблицы, будут просуммированы все значения среднего бала, которые относятся к мальчикам.

Теперь давайте растянем формулу по столбцу. Конечно, можно также прописать ее и для девочек, но если у Вас много разных критериев – это займет немало времени. Закрепим диапазоны для столбцов С и D, чтобы при копировании формулы они не ползли вниз.

Выделяем ячейку G4 и в «Строке формул» после D2, D26, C2, C26 нажимаем клавишу «F4». В адресах на ячейки, появятся знаки «$». Таким образом, мы делаем ссылки абсолютными. Чтобы растянуть формулу по столбцу, потяните за правый нижний угол ячейки, курсор изменит при этом вид на черный плюсик.

Если Вам интересно, как сделать ссылки в Эксель: абсолютные, относительные, на другой лист или книгу, прочтите статью по этой теме.

Дальше смотрим на «Строку формул». В качестве аргументов для Диапазона и Диапазона суммирования берутся правильные значения: D2:D26, C2:C26. В качестве Критерия укажите адрес нужной ячейки. Поскольку, нужно посчитать средний балл для всех девочек, в столбце D выбираем адрес любой ячейки, в которой указано «девочка»: D4.

Теперь рассмотрим аргументы для функции СУММЕСЛИМН в Excel.

=СУММЕСЛИМН(диапазон суммирования; диапазон условия1; условие1; диапазон условия2; условие2)

Диапазон суммирования – это столбец, значения из которого будут выбираться, если они соответствуют одному и второму заданному условию. В примере, это С2:С26.

Диапазон условия1 – это первый диапазон для сравнения. Нужно выбрать пол ученика, поэтому диапазон D2:D26.

Условие1 – нужно указать то значение, которое будет выбираться из Диапазона условий1. Нас интересуют мальчики, поэтому укажем ячейку D3.

Диапазон условия2 – второй диапазон сравнения. Здесь будем выбирать класс, в котором учится ребенок. Соответственно укажем диапазон В2:В26.

Условие2 – конкретное значение, которое нас интересует из Диапазона условий2. Сначала нужно будет выделить ячейку, в которой указан «8 класс», затем «9 класс».

Пример функции СУММЕСЛИМН.

Решать будем вторую задачу. Выделяем ячейку Н8, ставим «=», пишем СУММЕСЛИМН и открываем скобку «(». В качестве Диапазона суммирования указываем столбец со «Средним балом»: С2:С26. Диапазон условия1 – это пол ученика: D2:D26, Условие1 – это мальчики: ячейка D3. Диапазон условия2 – это класс:  В2:В26, Условие2 – 8 класс: ячейка В3. Закройте скобку, нажмите «Enter».

В «Строке формул» сразу сделайте абсолютные ссылки на столбцы: Класс, Средний бал, Мал/Дев.

Растягиваем формулу на ячейки Н8:Н11. Теперь укажем правильные ячейки в качестве Условия1 и Условия2.

В ячейке Н9 считается средний балл для мальчиков, которые учатся в 9 классе. Поэтому, Условие1 для первого диапазона «мальчик»: D3, Условие2 для второго диапазона «9»: В6.

В ячейке Н10 считаем средний балл девочек, которые учатся в 8 классе. Условие1 – «девочка», D4, Условие2 – «8», В3.

В ячейке Н11 считаем средний балл девочек, которые учатся в 9 классе. Условие1 – «девочка», D4, Условие2 – «9», В2.

Таким образом, мы посчитали сумму среднего балла для мальчиков и девочек, которые учатся в 8 и 9 классах по отдельности.

Давайте теперь проверим, чтобы результат был правильным. Посчитаем сумму «Среднего бала» для всех значений в исходной таблице, для Задачи 1 и для Задачи 2. Сумма должна быть одинаковой.

Чтобы подробно узнать, как посчитать сумму в Эксель, перейдите по ссылке и прочтите статью.

Вот на таких несложных примерах мы разобрались, как работает функция СУММЕСЛИ и функция СУММЕСЛИМН в Эксель.



Поделитесь статьёй с друзьями:

Автор: Аня Каминская| Дата: 2016-05-03| Просмотров:(10874)| Комментов:(0)


Похожие записи на сайте






Комментарии:

Добавить Ваш комментарий:

Введите сумму чисел с картинки: